Login Page - Create Account

Support Board


Date/Time: Tue, 22 Sep 2026 12:01:27 +0000



AMP account and cannot connect to Rithmic

View Count: 622

[2026-08-04 14:27:59]
User368639 - Posts: 71
Good morning:

1) Bought an account from EliteTraderFunding yesterday. Data Feed: Rithmic

2) Just before that, I was trading my account at AMP Futures.

3) The AMP account number is "frozen" in the Trade Window. https://app.screencast.com/0GB8BPBiUcogE

3) Elite auto-filled the data for Data Trade Service Settings: https://app.screencast.com/qqrFAW84wGlBa

4) I am logged into Rithmic with TraderDashboard and my Elite account is visible.

5) There are no duplicates of Rithimic in the Task Manager

6) This is the message from Rithmic when I try to connect to data feed: https://app.screencast.com/BqaiUYPEiANUt

I apologize for not following your rules regarding attachments. My 84 yo mind could not keep track of them any other way.

Please help. Thank you. Teton works perfectly as always, but cannot get out of that AMP account.
[2026-08-04 14:40:55]
John - SC Support - Posts: 47955
Refer to the following:
Rithmic Trading Platform Service: Permission Denied Resolution Procedure

Also, you state " I am logged into Rithmic with TraderDashboard and my Elite account is visible." With the connectivity that Rithmic has in place with Sierra Chart, you can not be logged into that account from anywhere else, or Sierra Chart will not be able to connect. Make sure you are not logged in anywhere other than Sierra Chart to that account.
For the most reliable, advanced, and zero cost futures order routing, use the Teton service:
Sierra Chart Teton Futures Order Routing
[2026-08-05 00:22:23]
ChrisX - Posts: 14
I have a similar problem as above, connecting Rithmic to Sierra. I have been through the ' Rithmic Trading Platform Service: Permission Denied Resolution Procedure' but still have problems:

1. I can get a data feed if I use my Rithmic username and password but whilst the 'ticker' on the left of my chart moves with price, I have no bars on the chart (the chart is frozen.)
2. I have an Amp account (funded). I have completed the Rithmic 'agreement' and self certification'.
3. Previously I had AMP using CQG, 'top of the book' level 1 (I don't need market depth). I had live data through Sierra (package 11).
4 Today I asked Amp to change to Rithmic (because I have a funded prop account: 'TPT')
5. Amp have given me a 'Rithmic "Live" username', and a 'Rithmic "Live" password' (the username is an email address).
6. The amp credentials do not work when I put them into the Data Trade Service Settings in Sierra. There is no connection at all.
7. Should I be using the Amp username and password or the Rithmic one (my chart is frozen/ no candles, with Rithmic)?
8. I have tried under 'Service Settings' both with, and without, the Sierra 'Market Data user/PW' and 'Historical Data User/PW' fields.

In addition to this I understand that if my chart is using Denali data instead of Rithmic's data then [M] appears next to the trade symbol in the top line of each chart. The [M] appears whether the 'Market Data user/PW' and 'Historical Data User/PW' are completed or are left empty. I understand that I will only be getting Denali data if the 'Market Data user/PW' and 'Historical Data User/PW' fields are left empty. Therefore I cannot be sure that I am actually getting Denali data.

It's been a long day! Any help would be much appreciated!
[2026-08-05 12:58:38]
John - SC Support - Posts: 47955
In addition to this I understand that if my chart is using Denali data instead of Rithmic's data then [M] appears next to the trade symbol in the top line of each chart. The [M] appears whether the 'Market Data user/PW' and 'Historical Data User/PW' are completed or are left empty. I understand that I will only be getting Denali data if the 'Market Data user/PW' and 'Historical Data User/PW' fields are left empty. Therefore I cannot be sure that I am actually getting Denali data.

You have this incorrect. It doesn't matter if the "Market Data" and "Historical Data" Username/Password fields are filled in or not. If you are setup to get the data from our Denali Exchange Data Feed, then Sierra Chart uses that data - which is your case. If you were not setup for the data, then you would get the data from Rithmic.


3. Previously I had AMP using CQG, 'top of the book' level 1 (I don't need market depth). I had live data through Sierra (package 11).
4 Today I asked Amp to change to Rithmic (because I have a funded prop account: 'TPT')

We do not understand why you made a change with AMP. Your connection to a Prop Firm is completely separate from your live trading account. If you want to keep your AMP account using Rithmic, then that is fine, but if you are having issues related to this, then you may want to change it.

And if you are trading just the CME Group, then we would recommend using our Teton Order Routing service with AMP, as you will have better service and save some money. Refer to the following:
Sierra Chart Teton Futures Order Routing


6. The amp credentials do not work when I put them into the Data Trade Service Settings in Sierra. There is no connection at all.

What exactly is occurring? Are you getting a "Permission Denied" error, or something else?
For the most reliable, advanced, and zero cost futures order routing, use the Teton service:
Sierra Chart Teton Futures Order Routing
[2026-08-05 14:38:13]
ChrisX - Posts: 14
Thanks for replying. I don't have any error messages such as "Permission Denied". I have the following:

1. The ticker on the left hand side of my chart is moving with (I assume) the live price, however I have no corresponding bars/candles or cumulative delta etc.
2. I have (previously) set up my Sierra account (service pack 11) with Denali (CME level one/ Top of the Book)

3. I am now understanding that Denali is applied to my account and that I don't need to put Rithmic through Amp and that I can put my Rithmic credentials (provided by TakeProfitTrader) directly into the Data Trade Service settings ('DTSS').
4. So, I have now reconnected my CQG in AMP. I don't have any error messages.
5. I understand that if I connect this CQG setting once a month in the 'DTSS', then I will have access to CME data for the month.
6. Is it correct that I can then change the 'DTSS' to my Rithmic credentials and only go back to CQG once a month?
7. Previously my charts functioned correctly but now the ticker is moving but I have no bars.

Thank you for the suggestion to Use 'Teton'. I see that Teton is faster than CQG. What fees would I have to pay Amp to connect my CME data, (currently I am paying $5/month)?
[2026-08-05 15:28:44]
John - SC Support - Posts: 47955
To start with, we need for you to choose the service you want to work with so we can ensure that we are giving the correct information related to that service.

Therefore, setup your system to connect to whichever service you are wanting to work with. Once you have this setup, then get us your Message Log for a single symbol by following these instructions:
Follow the instructions here to clear the Message Log:
Message Log: Clearing the Message Log

Close all of the Chartbooks with "File >> Close All Chartbooks".

Open a single chart for the symbol you have an issue with through "File >> Find Symbol". Tell us that symbol of the chart. Tell us about *one* symbol only.

Disconnect from the data feed with "File >> Disconnect".

Connect to the data feed with "File >> Connect to Data Feed".

After the connection and after about 10 seconds, provide a copy of the Message Log following these instructions:
Support Board Posting Information: How to Post Your Message Log (Required In Some Cases)


3. I am now understanding that Denali is applied to my account and that I don't need to put Rithmic through Amp and that I can put my Rithmic credentials (provided by TakeProfitTrader) directly into the Data Trade Service settings ('DTSS').

You put in the credentials for whatever service you are wanting to connect to. If you want to connect to your TakeProfitTrader account, then you need to enter those credentials. If you want to connect to another service, then you would enter those credentials.


4. So, I have now reconnected my CQG in AMP. I don't have any error messages.

You have us a bit confused by this. If you told AMP to change your account to use Rithmic, then they would have made this change.

We think you were getting things confused between AMP and TakeProfitTrader. If you are still setup with CQG with AMP, then you would need to connect to that CQG account at least once a month to verify your non-professional standing for the CME Group.


5. I understand that if I connect this CQG setting once a month in the 'DTSS', then I will have access to CME data for the month.

Correct.


6. Is it correct that I can then change the 'DTSS' to my Rithmic credentials and only go back to CQG once a month?

Yes - if you are not actually performing any trading with that AMP account. Refer to the following:
Denali Exchange Data Feed: Connecting Only Once a Month to Trading Account to Support CME Group Exchange Fees


Thank you for the suggestion to Use 'Teton'. I see that Teton is faster than CQG. What fees would I have to pay Amp to connect my CME data, (currently I am paying $5/month)?

If you are not actively trading the AMP account, then it does not matter what order routing service you are using. The money you would save is related to the Order Routing fees, for which you pay probably $0.10 per side with CQG. Teton does not have any order routing fees.

It sounds like you are saying that you pay $5.00 per month to AMP for CQG data. Sierra Chart does not support data from CQG for the CME Group and EUREX; and you are getting your CME Group data from our Denali Exchange Data Feed. So if you are not using that CQG data for anything else (some other system you use) then let AMP know that you do not want to pay for that data.
For the most reliable, advanced, and zero cost futures order routing, use the Teton service:
Sierra Chart Teton Futures Order Routing
[2026-08-05 16:58:54]
ChrisX - Posts: 14
The chart just opened is for NQU6.CME.
I have entered my credentials for Rithmic (TakeProfitTrader) in the Data/Trade Service Settings.
Re item 4. I was originally using CQG through AMP to fund the CME data. This worked fine.
When I opened my TPT account (Rithmic) I asked Amp to swap my CQG acc for Rithmic. I think this was a mistake. So, I then asked Amp to change back to CQG. I have since reconnected with this CQG feed.
Now I have no bars on my charts.
6. I am not trading an Amp account, I am just using them as a funded ($100) account to pay for my CME data. I am not using CQG for anything else except for creating a connection on the Sierra Data/Trade Service Settings. Have I misunderstood this? If I not need CQG and I am using Teton, will amp just continue to debt my account for the $5 each month?

You have suggested Teton. I have asked amp to enable Teton and I am awaiting their response.
If I am using Teton will I have to connect my Data/Trade Service Settings once a month and will I use 'Teton CME Routing (Trading)' in the drop down 'Services' menu?

Message log:

2026-08-05 12:32:30.237 | Software version: 2915 64-bit
2026-08-05 12:32:30.237 | Primary Thread ID: 20312
2026-08-05 12:32:30.237 | Usage end date: 2026-11-24
2026-08-05 12:32:30.237 | Enabled for: Advanced Features 2.
2026-08-05 12:32:30.237 | Enabled for: Sierra Chart Historical Data Service.
2026-08-05 12:32:30.237 | Enabled for: Denali Real-Time Exchange Data Feed.
2026-08-05 12:32:30.237 | Enabled for: Delayed Denali Exchange Data Feed.
2026-08-05 12:32:30.237 | Enabled for exchange2: CME
2026-08-05 12:32:30.237 | Allow Support for Sierra Chart Data Feeds is enabled.
2026-08-05 12:32:30.237 | Current selected Data/Trading service: Rithmic Direct - DTC
2026-08-05 12:32:30.237 | Custom symbol settings values: enabled
2026-08-05 12:32:30.237 | Chart Update Interval: 400
2026-08-05 12:32:30.237 | Intraday Data Storage Time Unit: 0
2026-08-05 12:32:30.237 | Time Zone: -04:00:00 (EST-05EDT+01,M3.2.0/02:00,M11.1.0/02:00)
2026-08-05 12:32:30.237 | 2026-08-05 16:32:30 Local computer time in UTC
2026-08-05 12:32:30.237 | 2026-08-05 12:32:30 Local computer time in SC Time Zone
2026-08-05 12:32:30.237 | 2026-08-05 10:26:22 Server time in UTC
2026-08-05 12:32:30.237 | Local computer UTC time and Server UTC time difference: 2 seconds.
2026-08-05 12:32:30.237 | Program path: Y:\SierraChart\
2026-08-05 12:32:30.237 | Data Files path: Y:\SierraChart\Data\
2026-08-05 12:32:30.239 | OS Version Number: 10.0
2026-08-05 12:32:30.239 | Locale Setting: C
2026-08-05 12:32:30.239 | Crash reporter started: true
2026-08-05 12:32:30.239 |
2026-08-05 12:32:33.009 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:32:33.009 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:32:38.022 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:32:38.022 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:32:43.033 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:32:43.033 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:32:48.036 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:32:48.036 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:32:53.037 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:32:53.037 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:32:58.047 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:32:58.047 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:03.047 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:03.047 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:08.047 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:08.047 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:13.052 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:13.052 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:18.055 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:18.055 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:23.058 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:23.058 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:28.060 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:28.060 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:33.063 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:33.063 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:38.067 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:38.067 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:38.646 | NQU6.CME 1 Min #1 | Reloading chart.
2026-08-05 12:33:38.789 | NQU6.CME 1 Min #1 | Chart data loading complete.
2026-08-05 12:33:43.078 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:43.078 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:48.086 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:48.086 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:53.097 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:53.097 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:58.104 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:33:58.105 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:34:03.119 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:34:03.119 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:34:08.121 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:34:08.121 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:34:13.128 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:34:13.128 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:34:18.115 | File >> Disconnect selected.
2026-08-05 12:34:18.115 | Rithmic Direct - DTC | Waiting for socket receive thread to end
2026-08-05 12:34:18.116 | DTC Client socket (1) | CloseSocket call.
2026-08-05 12:34:18.116 | DTC Client socket (1) | Shutdown started. Waiting for graceful close.
2026-08-05 12:34:18.116 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:34:18.117 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:34:18.118 | Denali Data Feed | Waiting for socket receive thread to end
2026-08-05 12:34:18.118 | DTC Client socket (3) | CloseSocket call.
2026-08-05 12:34:18.118 | DTC Client socket (3) | Shutdown started. Waiting for graceful close.
2026-08-05 12:34:18.118 | Denali Data Feed | Disconnected from the server.
2026-08-05 12:34:18.118 | Rithmic Direct - DTC | Disconnected.
2026-08-05 12:34:18.215 | DTC Client socket (1) | Socket gracefully closed by remote side.
2026-08-05 12:34:18.215 | DTC Client socket (1) | Closed.
2026-08-05 12:34:18.339 | DTC Client socket (3) | Socket gracefully closed by remote side.
2026-08-05 12:34:18.339 | DTC Client socket (3) | Closed.
2026-08-05 12:34:31.492 |
2026-08-05 12:34:31.492 | Rithmic Direct - DTC | Using server connection: Rithmic Paper Trading-Chicago Area-Non-Aggregated
2026-08-05 12:34:31.492 | Rithmic Direct - DTC | Trading server address/port: rsc.rithmic.com:50500
2026-08-05 12:34:31.492 | Rithmic Direct - DTC | Connecting to the server rsc.rithmic.com. Port 50500
2026-08-05 12:34:32.801 | DTC Client socket (1) | Creating socket. Using TLS 1.2.
2026-08-05 12:34:32.802 | DTC Client socket (1) | New receive buffer size: 0
2026-08-05 12:34:32.802 | DTC Client socket (1) | Connecting to IP: 38.65.210.70.
2026-08-05 12:34:32.899 | Rithmic Direct - DTC | Network connection to server complete.
2026-08-05 12:34:32.899 | Rithmic Direct - DTC | Starting socket receive thread.
2026-08-05 12:34:32.900 | Rithmic Direct - DTC | Using fixed encoding of Binary
2026-08-05 12:34:32.900 | Rithmic Direct - DTC | Sending logon request message.
2026-08-05 12:34:33.206 | Rithmic Direct - DTC | Received logon response.
2026-08-05 12:34:33.206 | Rithmic Direct - DTC | Server Name: .
2026-08-05 12:34:33.206 | Rithmic Direct - DTC | Server protocol version: 8. Client protocol version: 8
2026-08-05 12:34:33.206 | Rithmic Direct - DTC | Successfully connected.
2026-08-05 12:34:33.206 | Rithmic Direct - DTC | Trading is supported.
2026-08-05 12:34:33.206 | Rithmic Direct - DTC | Order cancel and replace is supported.
2026-08-05 12:34:33.206 | Rithmic Direct - DTC | OCO Orders supported.
2026-08-05 12:34:33.206 | Rithmic Direct - DTC | Symbol and Exchange Delimiter: .
2026-08-05 12:34:33.206 | Rithmic Direct - DTC | MarketDepthIsSupported: 0
2026-08-05 12:34:33.206 | Rithmic Direct - DTC | Connection to server complete.
2026-08-05 12:34:33.214 | No download requests in the queue to start downloads for. | Number times message added: 3
2026-08-05 12:34:33.492 | Mapping NQU6.CME to NQU26. Service code: cme
2026-08-05 12:34:33.492 | Using symbol data fast lookup vector
2026-08-05 12:34:33.492 | Denali Data Feed | Starting real-time market data updates for: NQU6.CME (NQU26). ID: 1 Service code: cme
2026-08-05 12:34:33.492 | Denali Data Feed | Connecting to the server ds25.sierracharts.com. Port 10048
2026-08-05 12:34:33.492 | Denali Data Feed | Requesting security definition data for: NQU6.CME (NQU26). ID: 1
2026-08-05 12:34:33.492 | Added historical Intraday data request for NQU6.CME to the queue.
2026-08-05 12:34:33.492 | Intraday data recording state for symbol NQU6.CME is set to download 'Pending'.
2026-08-05 12:34:33.492 | Triggering next historical data download in queue.
2026-08-05 12:34:33.503 | Delaying start of download for NQU6.CME.
2026-08-05 12:34:33.509 | DTC Client socket (2) | Creating socket.
2026-08-05 12:34:33.510 | DTC Client socket (2) | New receive buffer size: 0
2026-08-05 12:34:33.510 | DTC Client socket (2) | Connecting to IP: 64.152.155.20.
2026-08-05 12:34:33.620 | Denali Data Feed | Network connection to server complete.
2026-08-05 12:34:33.620 | Denali Data Feed | Starting socket receive thread.
2026-08-05 12:34:33.621 | Denali Data Feed | Sending encoding request to server: Binary VLS. Compression: standard
2026-08-05 12:34:33.738 | Denali Data Feed | Setting DTC encoding to Binary VLS
2026-08-05 12:34:33.738 | Denali Data Feed | Sending logon request message.
2026-08-05 12:34:34.330 | Denali Data Feed | Received logon response.
2026-08-05 12:34:34.330 | Denali Data Feed | Server Name: SC Realtime Server.
2026-08-05 12:34:34.330 | Denali Data Feed | Server protocol version: 8. Client protocol version: 8
2026-08-05 12:34:34.330 | Denali Data Feed | Successfully connected.
2026-08-05 12:34:34.330 | Denali Data Feed | Trading is not supported.
2026-08-05 12:34:34.330 | Denali Data Feed | MarketDepthIsSupported: 1
2026-08-05 12:34:34.330 | Denali Data Feed | Restarting real-time data updates for symbol: NQU6.CME -> NQU26
2026-08-05 12:34:34.518 | Denali Data Feed | Setting external service identifier for symbol NQU6.CME to 42004177
2026-08-05 12:34:34.518 | Denali Data Feed | Received security definition for symbol NQU6.CME
2026-08-05 12:34:39.766 | HD Request # 48 | Downloading Intraday chart data for NQU6.CME to the file NQU6.CME.scid. Service: cme
2026-08-05 12:34:39.769 | HD Request # 48 | Download start date-time: 2026-08-04 10:35:21.000000. File last date-time: 2026-08-04 10:35:21.890000
2026-08-05 12:34:39.769 | HD Request # 48 | Using server: ds28.sierracharts.com port 10149
2026-08-05 12:34:39.770 | Socket (3) | Creating socket.
2026-08-05 12:34:39.770 | Socket (3) | New receive buffer size: 0
2026-08-05 12:34:39.770 | Socket (3) | Connecting to IP: 67.214.125.5.
2026-08-05 12:34:39.982 | HD Request # 48 | Setting DTC encoding to Binary VLS
2026-08-05 12:34:39.982 | HD Request # 48 | Sending historical data logon request message.
2026-08-05 12:34:40.321 | HD Request # 48 | Requesting Intraday data. Start date-time: 2026-08-04 10:35:21. Record interval: 0. Symbol: NQU26
2026-08-05 12:34:40.431 | HD Request # 48 | Decompressing data.
2026-08-05 12:34:40.633 | HD Request # 48 | Receiving Intraday data for NQU6.CME starting at 2026-08-04 10:35:21.120000
2026-08-05 12:34:40.842 | HD Request # 48 | Error writing historical Intraday data. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk. * | Number times message added: 20
2026-08-05 12:34:43.365 | Socket (3) | CloseSocket call.
2026-08-05 12:34:43.365 | Socket (3) | Shutdown started. Waiting for graceful close.
2026-08-05 12:34:43.365 | Historical data download thread signaled to stop.
2026-08-05 12:34:43.366 | HD Request # 48 | Error writing historical Intraday data. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk. *
2026-08-05 12:34:43.366 | HD Request # 48 | Received 681599 Intraday data records from 2026-08-04 10:35:21.120000 to 2026-08-05 12:34:47.106000 (26.0 hours. Delay: -3.7 seconds) and wrote 0 records for NQU6.CME
2026-08-05 12:34:43.382 | HD Request # 48 | Add time&sales data | Remembered last file record date-time: 2026-08-05 16:34:47.106000
2026-08-05 12:34:43.382 | HD Request # 48 | Completion time: 4s.
2026-08-05 12:34:43.382 | HD Request # 48 | Intraday data download complete for NQU6.CME. Unique request ID: 48
2026-08-05 12:34:43.382 | Removing historical data download ID 48.
2026-08-05 12:34:43.382 | Real-time Intraday chart data file updates started for NQU6.CME
2026-08-05 12:34:43.382 | Intraday chart data file opened for NQU6.CME
2026-08-05 12:34:43.382 | HD Request # 48 | Enabling Intraday chart updating for symbol.
2026-08-05 12:34:43.382 |
2026-08-05 12:34:43.382 | No download requests in the queue to start downloads for.
2026-08-05 12:34:43.470 | Socket (3) | Socket gracefully closed by remote side.
2026-08-05 12:34:43.471 | Socket (3) | Closed.
2026-08-05 12:34:48.186 | Opened cached Intraday file: Y:\SierraChart\Data\NQU6.CME.scid. Thread ID: 20240
2026-08-05 12:34:48.186 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:34:51.589 | HTTPS connection ID:4 to downloads.rithmic.com:443 for request ID:4 (3) | Creating socket. Using TLS 1.2.
2026-08-05 12:34:51.589 | HTTPS connection ID:4 to downloads.rithmic.com:443 for request ID:4 (3) | New receive buffer size: 0
2026-08-05 12:34:51.589 | HTTPS connection ID:4 to downloads.rithmic.com:443 for request ID:4 (3) | Connecting to IP: 38.79.0.89.
2026-08-05 12:34:52.331 | HTTPS connection ID:4 to downloads.rithmic.com:443 for request ID:4 (3) | Socket gracefully closed by remote side. | Number times message added: 1
2026-08-05 12:34:52.339 | Rithmic Direct - DTC | Wrote file: Y:\SierraChart\RithmicConnections.json. Size: 115672
2026-08-05 12:34:52.340 | Rithmic Direct - DTC | Processed connection points. Count: 496
2026-08-05 12:34:52.340 | HTTPS connection ID:4 to downloads.rithmic.com:443 for request ID:4 (3) | CloseSocket call.
2026-08-05 12:34:52.340 | HTTPS connection ID:4 to downloads.rithmic.com:443 for request ID:4 (3) | Graceful close received or receive error. Shutdown complete. Closing socket now.
2026-08-05 12:34:52.340 | HTTPS connection ID:4 to downloads.rithmic.com:443 for request ID:4 (3) | Closed.
2026-08-05 12:34:53.188 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.
2026-08-05 12:35:03.212 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk. | Number times message previously added: 1
2026-08-05 12:35:13.232 | Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\NQU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk. | Number times message previously added: 1
[2026-08-05 18:07:20]
ChrisX - Posts: 14
Further to my last message which included the message log, it would appear that my hard drive is full. In particular the Sierra data folder has the largest volume. There are a lot of 1gb or 2gb files, in particular files ending in '.scid'.
[2026-08-05 18:32:05]
John - SC Support - Posts: 47955
Yes, your drive is full per this message:
Error writing to cached Intraday data file. Error writing record to the file Y:\SierraChart\Data\ESU6.CME.scid. Error: File error: Windows error code 112: There is not enough space on the disk.

You need to clear up some space in order for the data to be written to the drive. Refer to the following for how to clear out space from Sierra Chart:
Chart Data and Chart Data Files: Cleaning Up Old and Unused Symbols for Efficiency
For the most reliable, advanced, and zero cost futures order routing, use the Teton service:
Sierra Chart Teton Futures Order Routing
[2026-08-15 13:05:24]
ChrisX - Posts: 14
Just a quick note for any other Sierra users that have experienced the same problem of 'no chart data/bars' due to a full hard drive, I have noticed that my sierrachart/Data folder includes the '.scid' files that are associated with each chart. Many of these are huge. When I start Sierra multiple demo charts open. I have to close these every time before opening my actual charts. To free up space I have found that if I delete these charts upon open, save and then close Sierra, then these charts no longer appear on start up. I then delete their associated '.scid' files. This frees up a massive amount of space. Word of caution, if you don't delete the demo charts that appear on open then the 'scid' file is reinstated in the data folder and they immediately start filling up again.

I haven't seen this in the section 'Cleaning Up Old and Unused Symbols for Efficiency' so if it is not there it might be an idea for Sierra to add it.

('Cleaning Up Old and Unused Symbols for Efficiency' found at: Chart Data and Chart Data Files: Cleaning Up Old and Unused Symbols for Efficiency)
[2026-08-16 21:53:38]
Sierra_Chart Engineering - Posts: 24928
We will update the documentation regarding this. However, what you need to do is simply prevent the example Chartbook from opening by removing it from the Files to Open on Startup list:
General Settings Window: Startup (Global Settings >> General Settings >> General)
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. Try to keep your questions brief and to the point. Be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

For the most reliable, advanced, and zero cost futures order routing, use the Teton service:
Sierra Chart Teton Futures Order Routing

To post a message in this thread, you need to log in with your Sierra Chart account:

Login

Login Page - Create Account