Login Page - Create Account

Support Board


Date/Time: Sun, 04 Dec 2022 21:08:14 +0000



bug on chartbook

View Count: 108

[2022-10-03 15:05:32]
User543772 - Posts: 5
https://www.sierrachart.com/image.php?Image=1664809350129.png

https://www.sierrachart.com/image.php?Image=1664809408527.png

Hi, I have a problem. I have a saved chartbook for SP500 with "vwap" and "volume by price studies". (See link 1) But the chart seem bugged to me, they have a blank space at the far right and the volume by price study is not displayed correctly: insted of showing every week in a separate volume profile, multiple week/months are merged together. Same problem on the daily vwap chart.(see link 2).
I need to specify that I have the same settings saved for multiple chartbooks and for example Crude Oil and EuroBund are displayed correctly, The ES Mini by CME is the only one that is not displayed correctly.
I'll attach the chartbook to this message.

let me know how to fix this issue if possile, thanks
attachmentVWAP_CHARTBOOK_SP500.Cht - Attached On 2022-10-03 14:49:51 UTC - Size: 38.76 KB - 16 views
[2022-10-03 17:34:12]
John - SC Support - Posts: 20295
Everything looks fine to us.

First, with regards to the space on the right, refer to the information for Lock Fill Space, which you have enabled:
Chart Settings: Lock Fill Space (Chart >> Chart Settings >> Display menu)

With regards to the Volume by Price profiles, we are seeing multiple profiles as specified for each chart. The one profile on the far right is the most recent one and shows up on the far right because you have the options for Right-Align Volume Bars and Align to Far Right both set to Yes.
For the most reliable, advanced, and zero cost futures order routing, use the Teton service:
Sierra Chart Teton Futures Order Routing
[2022-10-04 09:40:18]
User543772 - Posts: 5
https://www.sierrachart.com/image.php?Image=1664875783712.png

I'll try to be a bit more specific about my issue: according to my settings I should be seeing a volume for every week. I setted the study to "multiple profiles based on fixed time" and my fixed time is 1 week. I've drawn two arrows on the chart where I see the profiles missing. Moreover even with "lock fill space" disabled I still see the blank on the far right and I'm not able to remove it. I'm NOT talking about the space between the price candles and the volume profile; I'm talking about the blank space beyond the volume profile at the far right just before the window ends. That space looks like a bug, I haven't seen something like that in any of my other chartbooks.
[2022-10-04 10:09:26]
User543772 - Posts: 5
https://www.sierrachart.com/image.php?Image=166487789459.png

I've also noticed this: As shown in the screenshot, everything was looking fine until 22/9/19. Where you can see that blue error in the candles display and everything started being displayed wrong after that. This doesn't seem to me like an error in my settings, it looks like an error in the way the data are interpreted and displayed, correct me if I'm wrong.
[2022-10-04 16:27:00]
John - SC Support - Posts: 20295
We opened your Chartbook again and the link below shows you what we see. Everything looks good, and we see the weekly profiles as expected.
https://www.sierrachart.com/image.php?Image=1664900513837.png

Your data does not look correct around between the 14th and the 19th. You should delete the data from just before then and redownload and see if it corrects the issue you are having. Refer to the following instructions:
Data Errors or Spikes in Charts, Flat or Flat Line Graph, Compressed Graph, Errors with Date/Time Values: 2.1.2 Deleting and Re-downloading Data. (Easier and Recommended Method)

We do not see the blue error in the candles when we open your chartbook. Deleting the data from the one chart should resolve the issue for all your charts, as it really seems there is some incorrect data around the 14th/19th.
For the most reliable, advanced, and zero cost futures order routing, use the Teton service:
Sierra Chart Teton Futures Order Routing
[2022-10-04 18:02:30]
User543772 - Posts: 5
Deleting and re-downloading the data solved the issue. Thank you very much for your time.

To post a message in this thread, you need to log in with your Sierra Chart account:

Login

Login Page - Create Account