Login Page - Create Account

Support Board


Date/Time: Thu, 21 Oct 2021 14:58:28 +0000



Custom symbols not working with numbers

[2021-10-11 19:39:40]
Matt NL - Posts: 70
Could someone please help me get a simple test custom symbol working?
It seems whenever I use a multiplier it fails.

For example, this works ok...
{X.US.VOLQ}-{X.US.VOLI}

But this fails...
2*{X.US.VOLQ}

Log file states:
2*{X.US.VOLQ}-{X.US.VOLI} Daily #13 | Currently no data in file to display. Will start historical data download and real-time updates. File: C:\SierraChart\Data\2%{X.US.VOLQ}-{X.US.VOLI}.dly | 2021-10-11 14:36:06.286

But it doesn't download anything or do anything further.

What am I doing wrong?

Thanks
Matt
[2021-10-12 18:40:00]
Sierra_Chart Engineering - Posts: 1961
Custom calculated symbols do not work with historical Daily charts.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation
Date Time Of Last Edit: 2021-10-12 18:40:06
[2021-10-12 19:35:35]
Matt NL - Posts: 70
Thank you but I also tried intraday.

Here's a complex example that's working perfectly...
{X.US.SDEX}/average({X.US.VOLI},{X.US.VOLQ})

But if I do this (adding 2* at the beginning)...
2*{X.US.SDEX}/average({X.US.VOLI},{X.US.VOLQ})

..it won't work.

Just wondering if I'm doing something wrong.

Another question... if I go offline / computer on standby during the day, when I come back and reconnect my data it won't pull down the missing data from when I was offline. So I get a gap in the middle. I can fix this by deleting and re-downloading all data again, but I don't want to lose all my historical data. Is there any reason why this might be happening?

Thanks
Matt
[2021-10-13 20:12:14]
Sierra_Chart Engineering - Posts: 1961
1. We will check on this.

2.
if I go offline / computer on standby during the day, when I come back and reconnect my data it won't pull down the missing data from when I was offline. So I get a gap in the middle. I can fix this by deleting and re-downloading all data again, but I don't want to lose all my historical data. Is there any reason why this might be happening?
It sounds like one or more of the historical data downloads are failing.



You only need to follow the instructions here:
https://www.sierrachart.com/index.php?page=doc/HistoricalIntradayData.html#RetryDownloadDataInChart
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation
Date Time Of Last Edit: 2021-10-13 20:12:35
[2021-10-13 20:34:09]
Sierra_Chart Engineering - Posts: 1961
We tested this and did not encounter a problem:
2*{EURUSD}-{EURGBP}

So we do not know what the issue is in your case. We cannot test those symbols.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation
[2021-10-14 08:37:43]
Matt NL - Posts: 70
Sorry I stand corrected... it now works!
I've no idea why it now works, I didn't change anything.
It might be because it's a new symbol at CQG which they hadn't 100% finished adding or something.

I'll check later if the missing data problem is also fixed (it's only during market hours so I'll have to get back to you).

Thanks again

To post a message in this thread, you need to login with your Sierra Chart account:

Login

Login Page - Create Account