Login Page - Create Account

Support Board


Date/Time: Thu, 18 Oct 2018 04:18:31 +0000



CQG Historical Intraday Data Missing on F.US.MJNK?##

Support Request:
[2017-12-17 21:24:51]
User13 - Posts: 4
Hi,

I'm connected to CQG via FIX and when I configure a continuous contract on MJNKH18 I only get intraday chart data back to the rollover date of 12/7. When I check Global Symbol Settings, it is using 'method3' as a rollover rule and appears to calculate rollover dates correctly.

If I disable continuous contracts it shows intraday data back to 11/20 or so, which I believe corresponds to when the H18 contract started trading.

If I switch to a historical chart, I get data going back as far as I care to go.

How can I get the historical data from older contracts to show up on intraday charts?

Thanks.
[2017-12-17 21:55:55]
Sierra Chart Engineering - Posts: 64936
Follow the instructions here:

https://www.sierrachart.com/index.php?page=doc/ContinuousFuturesContractCharts.html#ReDownloadingContinuousFuturesContractData

Be sure to follow all of the steps including updating the Symbol Settings.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

If your question/request has been answered and you do not have anything further, then it is easiest for us if you do not reply again to say thank you.
Date Time Of Last Edit: 2017-12-17 21:56:27
[2017-12-18 00:11:54]
User13 - Posts: 4
I've completed those steps before but I just went through all steps again, including updating symbols. I'm still only getting data on the H8 contract, though I was prompted for - and downloaded - the last 3 contracts (U7, Z7, H8) when I re-downloaded all data.

Still nothing on my intraday chart prior to 12/7 rollover.
[2017-12-18 03:55:22]
Sierra Chart Engineering - Posts: 64936
This is what we see:
http://www.sierrachart.com/image.php?Image=151356924775.png

You cannot see it but at the lower left, it says December 17 indicating that the first bar in the chart is where the December 2017 contract starts.


Provide an image of the chart or Trade DOM, by following these instructions:
https://www.sierrachart.com/index.php?page=doc/PostingInformation.php#Image
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

If your question/request has been answered and you do not have anything further, then it is easiest for us if you do not reply again to say thank you.
Date Time Of Last Edit: 2017-12-18 03:56:21
[2017-12-18 06:53:47]
Sierra Chart Engineering - Posts: 64936
We think we know what the problem was.

It is now corrected.

It was not something we could duplicate because we were not using CQG FIX Trading but instead the CQG Web API for testing.

Follow the instructions here to update the Symbol Settings:
https://www.sierrachart.com/index.php?page=doc/GlobalSymbolSettings.php#UpdateSettings

Re-download all the data in the chart by going to the chart and selecting "Edit >> Delete All Data and Download".
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

If your question/request has been answered and you do not have anything further, then it is easiest for us if you do not reply again to say thank you.
[2017-12-18 12:38:27]
User13 - Posts: 4
You're right. It does seem to work right with the Web API. I do like using OCO orders, which is why I'm looking at FIX.

I tried reconnecting/reloading data when on FIX but I'm still not able to get the historical data loaded on that connection. What actions do I need to take to actually get the data? Is there an update that I need to fetch?

Thanks!
[2017-12-18 17:48:16]
Sierra Chart Engineering - Posts: 64936
We have verified this issue was resolved. We just verified this again.

Follow the instructions here to update the Symbol Settings:
https://www.sierrachart.com/index.php?page=doc/GlobalSymbolSettings.php#UpdateSettings

Follow the instructions here to clear the Message Log:
https://www.sierrachart.com/index.php?page=doc/MessageLog.html#Clearing

Right-click somewhere on the chart, and select Delete and Download Data.

Provide a copy of the Message Log by following these instructions:
https://www.sierrachart.com/index.php?page=doc/PostingInformation.php#MessageLog
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

If your question/request has been answered and you do not have anything further, then it is easiest for us if you do not reply again to say thank you.
Date Time Of Last Edit: 2017-12-18 17:48:36
[2017-12-18 19:31:06]
User13 - Posts: 4
I did try updating symbol settings and re-downloading initially but now that I've tried WebAPI and then switched back to FIX it seems to be working as expected.

Thanks for your help!

To post a message in this thread, you need to login with your Sierra Chart account:

Login


Login Page - Create Account