Login Page - Create Account

Support Board


Date/Time: Mon, 22 Jan 2018 02:37:18 +0000



Trade Simulation - Orders not filling - What setting am I missing?

Support Request:
[2017-12-15 20:01:37]
Mooshu22 - Posts: 11
I have been trying to setup backtesting for my trade signals. I had a few successful runs at testing some conditions and then the orders stopped filling in the simulation. I must have inadvertently switched a setting and I can't figure out how to get back rolling again.

Here is where I am at: I am using the "Spreadsheet System for Trading" study and then entering conditions into the BUY Entry and SELL Entry fields row 3, columns K and M. The spreadsheet is showing TRUE and FALSE data,0's and 1's, based on the conditions. The data feed is disconnected. User is set to SIM1. Trade Simulation is checked. Auto Trading Enabled is checked. When I run the Autotrade System Bar Based Back Test it finishes with no errors and the entry arrows are marked on the chart. Then checking the Trade Activity Log I don't have any trade statistics, everything is at 0 still. In the Trade Activity tab I only have activity for orders and no fills. I've been stuck for a while need to reach out for help. Thanks-
imageTroubleshooting - Autotrade Sim.png / V - Attached On 2017-12-15 19:48:38 UTC - Size: 63.07 KB - 19 views
[2017-12-15 23:25:16]
Sierra Chart Engineering - Posts: 56344
Refer to this section here for help with this:
https://www.sierrachart.com/index.php?page=doc/SpreadsheetSystemsAlertsAndAutomatedTrading.php#IgnoredSignalsWithSpreadsheetSystemsOrAlerts (Ignored Signals With Spreadsheet Systems Or Alerts)

Also the controls at the top of the Trade Activity Log you posted a screenshot of, are not set correctly. You need to select the particular simulated Symbol and the simulated trading Account. Follow the instructions here:
https://www.sierrachart.com/index.php?page=doc/TradeActivityLog.php#ViewingHistoricalTradeActivity
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

If your question/request has been answered and you do not have anything further, then it is easiest for us if you do not reply again to say thank you.
Date Time Of Last Edit: 2017-12-18 17:56:19
[2017-12-18 16:45:56]
Mooshu22 - Posts: 11
Thank you for the reply. My issue was that the "Trade >> Auto Trading Enabled - Global" setting was not checked but the "Trade >> Auto Trading Enabled - Chart" was.

I am reading up on the "Trade Service Account Balance" which reflects the account balance supplied by your trade service on a live account. Is there a way to give your SIM accounts an account balance so the results of the back testing reflect an account with money in it?
[2017-12-18 17:57:02]
Sierra Chart Engineering - Posts: 56344
Account balances are not supported in Trade Simulation Mode. At some point this will be.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

If your question/request has been answered and you do not have anything further, then it is easiest for us if you do not reply again to say thank you.
[2017-12-18 18:40:10]
Mooshu22 - Posts: 11
Ok. That would be a really nice feature! Thanks for saving me the time of trying to figure it out. I appreciate all the support help. Thank you-

To post a message in this thread, you need to login with your Sierra Chart account:

Login


Login Page - Create Account