Login Page - Create Account

Support Board


Date/Time: Thu, 29 Oct 2020 07:49:37 +0000



SC holding old 'Set Default' values on new dll build

[2020-09-23 15:30:22]
User681150 - Posts: 56 | Ending Date: 2020-11-12
in prev DLL builds i would "Set Defaults" in certain inputs to specific studies, so i didnt have to manual do it every time i re-built a dll when testing

i made some changes to my default values in my acsil .cpp file and built the new dll.

i noticed my new default settings from my acsil would not take (line coloring, width, drawstyle, etc). SC would still load the old settings even on a new DLL build. i would then have to "reset defaults", then set defaults again...

to me this seems illogical (i can understand built-in indicators but not DLL files with potential new settings)

just an FYI, not sure if this is what you intended on custom acsil
Date Time Of Last Edit: 2020-09-23 17:00:16
[2020-09-23 17:47:03]
Sierra Chart Engineering - Posts: 90799 | Ending Date: 2021-04-05
If you are not removing the study from the chart and adding it again, then yes all of the Input Settings in the sc.SetDefaults code block are definitely not going to change back to defaults.


Nothing has changed in this regard.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

If your question/request has been answered and you do not have anything further, then it is easiest for us if you do not reply again to say thank you.
Date Time Of Last Edit: 2020-09-23 17:47:27
[2020-09-30 21:51:51]
User681150 - Posts: 56 | Ending Date: 2020-11-12
thanks. But even when i rebuild the DLL AND remove the study and add it back in... it still picks up the "saved defaults". the only way not to use the saved defaults is either rename the dll OR click the "reset defaults".

so removing and adding it back DOES NOT reset the defaults after rebuilding a DLL (my observations). some how SC is saving the settings based on the name of the study even after rebuilding dll
[2020-09-30 23:51:34]
Sierra_Chart Engineering - Posts: 856 | Ending Date: 2021-01-07
it still picks up the "saved defaults".
Yes this is true.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

To post a message in this thread, you need to login with your Sierra Chart account:

Login

Login Page - Create Account