Login Page - Create Account

Support Board


Date/Time: Sun, 26 Jun 2022 23:11:00 +0000



.NET 4.0 Error

View Count: 1799

[2013-04-10 14:27:29]
infpz - Posts: 826
Anyone see this before? http://screencast.com/t/OFN0JOqI

This person is trying to update .NET because 962 will not load after InfinityAT launches.

Log:
S Version = 5.1.2600, Platform 2, Service Pack 3
OS Description = WinXP - x86 Professional Service Pack 3
CommandLine = C:\b0f0d7dc79d3b1d14e\\Setup.exe /x86 /x64
TimeZone = Eastern Daylight Time
Initial LCID = 1033
Using Simultaneous Download and Install mechanism
Operation: Installing
Package Name = Microsoft .NET Framework 4 Setup
Package Version = 4.0.30319
User Experience Data Collection Policy: UserControlled
Number of applicable items: 6
ServiceControl operation succeeded!
MSI (C:\b0f0d7dc79d3b1d14e\netfx_Extended_x86.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20130410_102235859-MSI_netfx_Extended_x86.msi.txt
Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:00:40).


[2013-04-10 16:18:49]
Sierra Chart Engineering - Posts: 103466
In general, we sometimes have seen errors with .NET updates like this. They are not easily resolved. They would have to find out from the Microsoft Knowledge Base what the error code means and follow the given solution.

We are working very aggressively now to get rid of this junk .NET from Sierra Chart. It is an absolute terrible thing.

This is the relevant error line:
Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. Try to keep your questions brief and to the point. Be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

For the most reliable, advanced, and zero cost futures order routing, *change* to the Teton service:
Sierra Chart Teton Futures Order Routing
Date Time Of Last Edit: 2013-04-10 16:20:17
[2013-04-10 16:39:11]
Sierra Chart Engineering - Posts: 103466
Just remembered we have a non-CLR/.NET version. They can install it using this link:
http://www.sierrachart.com/downloads/SierraChartSetupNoCLR.exe

The installation folder needs to be \SierraChart\SierraChartTransActMA

They do not have to mess around with .NET at all. When updating this one always use Help >> Download Latest Non-.NET Version

Although, there might actually be a small dependency on .NET in one of the TransAct libraries which would end up defeating this. We will check with Bob on this now.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. Try to keep your questions brief and to the point. Be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

For the most reliable, advanced, and zero cost futures order routing, *change* to the Teton service:
Sierra Chart Teton Futures Order Routing
Date Time Of Last Edit: 2013-04-10 16:40:17
[2013-04-10 17:16:03]
infpz - Posts: 826
OK, thanks, please let us know.
[2013-04-10 17:51:04]
Sierra Chart Engineering - Posts: 103466
Our recommendation is to try using the Sierra Chart non-CLR version and see what happens. TransAct has indicated that there still is a dependency on .NET for one of the files. Although it still might work.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. Try to keep your questions brief and to the point. Be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

For the most reliable, advanced, and zero cost futures order routing, *change* to the Teton service:
Sierra Chart Teton Futures Order Routing
[2013-04-14 21:50:11]
maxima120 - Posts: 139
We are working very aggressively now to get rid of this junk .NET from Sierra Chart. It is an absolute terrible thing.
4.5 years gone by but nothing changes under this sun :)
[2013-04-14 22:26:48]
Sierra Chart Engineering - Posts: 103466
What exactly do you mean by this? If you are indicating that we are taking a long time to remove .NET, then it is just simply time-consuming. The problem is there are several components which we do not develop which use it, so we have to find alternatives for them or build them ourselves.

At least we are doing this. We do not foresee .NET as the future. Developers should avoid it like the plague.

And for years now, we have also made our non-CLR version available. At this point the only limitations are that the Spreadsheet functionality is still under development.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. Try to keep your questions brief and to the point. Be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

For the most reliable, advanced, and zero cost futures order routing, *change* to the Teton service:
Sierra Chart Teton Futures Order Routing
Date Time Of Last Edit: 2014-01-18 00:36:43
[2014-01-17 23:16:33]
bwalks123 - Posts: 122
Is .Net version 4.5 suitable or does it have to be .Net 4.0?
Thanks
[2014-01-18 00:35:12]
Sierra Chart Engineering - Posts: 103466
4.5 is fine.

And to give you an update, we really are only 2 months away from completely dropping .NET. So you will not even need .NET on the computer to begin with. You can also use the non-CLR version:

http://www.sierrachart.com/index.php?l=doc/download.php

Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. Try to keep your questions brief and to the point. Be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

For the most reliable, advanced, and zero cost futures order routing, *change* to the Teton service:
Sierra Chart Teton Futures Order Routing
[2014-01-18 01:23:28]
bwalks123 - Posts: 122
Oh ok great
I am going to be paying for Sierra Chart package 3 and SC real time & historical feed with global futures/TTnet connection. I'm having issues downloading TT platform, keep receiving a message that says "ttm_api_4.2.dll" missing from computer? Any idea what this is? I'm still waiting to hear from TT support! Thx
[2014-01-18 02:40:05]
Sierra Chart Engineering - Posts: 103466
Not sure. That involves TT's own software.

You should not have any trouble installing Sierra Chart. The installation is very straightforward.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. Try to keep your questions brief and to the point. Be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

For the most reliable, advanced, and zero cost futures order routing, *change* to the Teton service:
Sierra Chart Teton Futures Order Routing

To post a message in this thread, you need to log in with your Sierra Chart account:

Login

Login Page - Create Account