Login Page - Create Account

Support Board


Date/Time: Fri, 27 Jan 2023 18:08:26 +0000



[User Discussion] - Linux

View Count: 57183

[2020-11-25 00:10:49]
Kiwi - Posts: 372
Linux networking is about as robust as it gets Ed so it shouldn't be the issue.

I would start by turning off any firewalls you might have running. After that, possibly share the log with Sierra Chart team and seeking support.
[2020-11-25 00:25:51]
Ed C. - Posts: 54
This is with Wine, so it wouldn't be with the Linux networking layer per se. I found out what it was:

"If you have a need to use the Denali Exchange Data Feed on a second computer at the same time, then you can pay for a second set of exchange fees."

Denali Exchange Data Feed: Denali Exchange Data Feed on Two Computers Simultaneously

This used to work, but no more, I suppose...
[2020-11-25 01:01:33]
ertrader - Posts: 568
Yes... the CME changes earlier in the year caused this. I have two full SC versions in their own directories running with their own data to address this. It works great as long as you are on the same computer. SC's and CME licensing allow this.
[2020-11-25 01:20:04]
Kiwi - Posts: 372
Distro-hopping continues.

Loved KDE Neon but discovered that the "KDE is as light as XFCE" argument was exactly half right. The half that was right was memory usage. The half that was wrong was CPU usage. I noticed over a few weeks that I seemed to be running 10C hotter than with Mint. I run fans ultra slowly for silence and speed them up reluctantly.

So I tried XFCE on Neon (Ubuntu LTS) and it lost the 10C & a little bit. And with a little playing I finally got XFCE looking as nice as Mint was - also install Terminator for a flexible terminal and Pcman-fm for a dual pane file manager (will drop to Caja if I hate it but I seem to have it working nicely now). No X11 issues.

So on Sunday I decided to switch to XFCE on Fedora 33. Up. Nice. I do quite like DNF. But, damn it, with the latest SC + wine 5-21 + X11 1.6.12 the darned problem was back. Not there on Buntu+Xfce but here now.

So this morning I compiled, installed, then copied the sos over the olds dlls. 1.7.0 and the problem has disappeared - thread safe and happy.

So, the plan is Fedora (let it drop off the bleeding edge though), XFCE (still can't love gnome), and X11 until Wayland lets me manage windows from user space. Maybe.

System:
Host: fedora Kernel: 5.9.9-200.fc33.x86_64 x86_64 bits: 64
Desktop: Xfce 4.14.3 Distro: Fedora release 33 (Thirty Three)
CPU:
Info: 6-Core AMD Ryzen 5 3600 [MT MCP] speed: 2089 MHz
min/max: 2200/3600 MHz
Graphics:
Device-1: NVIDIA GP108 [GeForce GT 1030] driver: nvidia v: 455.45.01
Display: x11 server: Fedora Project X.org 1.20.9 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa resolution: 1: 1920x1080~60Hz
2: 1920x1080~60Hz
OpenGL: renderer: GeForce GT 1030/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01
Drives:
Local Storage: total: 2.84 TiB used: 1.77 TiB (62.2%)
Info:
Processes: 319 Uptime: 13m Memory: 15.64 GiB used: 1.99 GiB (12.7%)
Shell: Zsh inxi: 3.1.08

wine-5.21 (Staging)

[2020-11-26 17:15:01]
ertrader - Posts: 568
I've updated mint linux using the same steps as before. Seems to be working well. There are some files that have ~1~ and higher #'s at the end of the filename. Does anyone know why the files are like that? Do I need to make sure they are the same as the main file name?

Example:
-rw-r--r-- 1 root root 34756864 Nov 24 05:55 libX11.a
-rw-r--r-- 1 root root 2253270 Aug 31 11:51 libX11.a.~1~
-rw-r--r-- 1 root root 34649350 Sep 28 14:20 libX11.a.~2~
-rw-r--r-- 1 root root 34649350 Sep 28 16:06 libX11.a.~3~
-rw-r--r-- 1 root root 34649350 Sep 28 16:08 libX11.a.~4~
-rw-r--r-- 1 root root 34655220 Oct 2 10:03 libX11.a.~5~
Date Time Of Last Edit: 2020-11-26 17:16:12
[2020-11-26 21:42:59]
Kiwi - Posts: 372
At a guess they're backups and the app/os is adding the squiggle tags on the end with each new one.

So only the most recently dated one matters to you.
[2020-11-26 22:53:13]
Kiwi - Posts: 372
If you want them here's the compiled 1.7.0 files along with the symlinks.

Save your own ones in a directory somewhere first ... or maybe add ~kiwi~ to the end of the old ones 😉
Date Time Of Last Edit: 2020-11-26 22:54:03
attachmentxlibs.zst - Attached On 2020-11-26 22:47:49 UTC - Size: 7.67 MB - 315 views
[2020-11-26 23:03:24]
Ed C. - Posts: 54
Yes, the squiggle files are the backups. You can just ignore them if you want.
[2020-12-04 03:45:43]
ertrader - Posts: 568
Latest X11 updates working well. Below is my latest configuration...no issues. Stable and fast.

Configuration:
SierraChart Version 2215 64 bit (2 instances)
wine-6.0-rc5
Mint Linux 20/Ubuntu 20.04/Cinnamon desktop
Kernel 5.8.0-33 generic
OpenGL X11lib: 1.7.0
AMD Ryzen 7 3800X
GeForce GTX 1660 Nvidia video card driver 455.45.01
Dual Monitors
Internet: 295bps, 4ms ping, Comcast, Houston

Updated
Date Time Of Last Edit: 2021-01-04 03:14:13
[2020-12-15 18:45:04]
AlexPereira - Posts: 193
heheh, posting phoronix news before Ganz :P

Seems wine on wayland is close ( not here yet but close ) :)

https://www.phoronix.com/scan.php?page=news_item&px=Wayland-Wine-Driver
[2021-01-07 11:54:05]
ganz - Posts: 1048
That's it!

https://www.phoronix.com/scan.php?page=news_item&px=NVIDIA-GL-VLK-XWayland
[2021-01-12 22:05:46]
ertrader - Posts: 568
Several updates and all working exceptionally well. Since moving to kernel 5.8, the AMD Ryzen has been rock solid. No issues at all updating to Mint Linux 20.1, Nvidia 460, SC 2222 or wine-6.0 Stable

Configuration:
SierraChart Version 2230 64 bit (2 instances)
wine-6.2 Development
Mint Linux 20.1/Cinnamon desktop
Kernel 5.8.0-43 generic
OpenGL X11lib: 1.7.0
AMD Ryzen 7 3800X
GeForce GTX 1660 Nvidia video card driver 460.39
Dual Monitors
Internet: 295bps, 4ms ping, Comcast, Houston
Updated 2/16/21
Date Time Of Last Edit: 2021-02-16 23:56:50
[2021-01-25 12:59:37]
Jezz - Posts: 31
Thanks everyone in this thread with helpful info.

I am preparing an AppImage for wine6 including libX11 1.7.0
I've made some tests and Sierra looks to work fine with this appimage.

I would like to hear some experiences on how the graphic card (GTX,..) improves Sierra performance as 2D graphics, And what settings are required.

Thanks
[2021-01-29 03:36:17]
ertrader - Posts: 568
Hi Jezz... I'm using default NVidia graphics settings with my GTX....nothing special. I do use OpenGL without any issues and have also used SC non-OpenGL settings with no issues. OpenGL "seems" to have better performance but frankly I'm unable to detect the difference.

At one point, CPU usage was significantly less with OpenGL but I have not seen this difference for many months. I run 2 SC's at the same time and each is 3 percent CPU usage with 250-450 MiB of ram... that's MiB...frankly cannot believe it all runs with such little memory. Wineserver takes another 3 percent CPU. It would be good to have some GPU performance results, however, with such good performance (loading, screen refreshes etc.), have not seen the need.

My chartbooks with 6 charts per chartbook (One chartbook for each instrument: ES, NQ, RTY and GC) load in less than 2 seconds per chartbook. Sometimes data loading takes a second or two longer. I do have another chartbook with 15 charts and it takes about 3 seconds. So, for all charts (39 charts) takes about 11 seconds.

Edit: Updated to 2225 memory usage now at 600 to 800 MiB. Will monitor. Still low but interesting increase.
Date Time Of Last Edit: 2021-01-30 01:44:08
[2021-01-30 15:32:02]
samual sprat - Posts: 343
Hi Guys,

So i'm testing out linux again given all the crap around privacy atm. Reason I moved away from linux in the first place was because for some reason on Manjaro (5.8), with NVIDIA gtx 1070, Wine 6.0 & OpenGl sierra was using 90-100% of my GPU and was laggy compared with windows. Without opengl, it's way more laggy so that's not an option

I decided to upgrade the OS today and am running same as above but now Linux 5.10 and Nvidia proprietary 460.32.03 in the hope that the GPU usage would come down to what i get in windows (50-70% max), but it's still pegged to 90-100% and laggy

FYI, the old linux friendly changes that I made to my chartbooks a year or so back (e.g. don't use 'Dot' line draw types as they cause performance issues) are not being adhered to anymore as I assumed these issues were fixed on linux when using OpenGl. Is this okay?

Anyone come across high GPU usage/lag on Nvidia and know of a fix (if one even exists)?

Thanks,
Sunny
[2021-01-30 19:41:08]
ertrader - Posts: 568
Have not had GPU laggy issues. Attached is the GPU performance for the GTX 1660 with Nvidia updated to Nvidia 460.39 running 2 instances and 39 charts with OpenGL. Kernel 5.8.0-41 generic. For about 6 months have not had to do anything special for OpenGL. Before, yes like you mentioned. At the command prompt I used the following to output to a text file: nvidia-smi > nvidia-output.txt.

Allow Flipping is off
Sync to VBlank is on
Image Settings: Quality
Use Conformant Texture Clamping is on
Enable Graphics API Visual Indicator is off
Enable FXAA is not checked
Anisotropic filtering is not checked
Date Time Of Last Edit: 2021-01-30 19:54:29
attachmentnvidia-output.txt - Attached On 2021-01-30 19:40:01 UTC - Size: 1.83 KB - 251 views
[2021-02-01 20:20:41]
ertrader - Posts: 568
In reviewing my Nvidia setup, I also enabled Persistence. Here is the link.
https://forums.developer.nvidia.com/t/setting-up-nvidia-persistenced/47986/11
[2021-02-01 21:24:38]
samual sprat - Posts: 343
Thanks @etrader. Is this to help with sierra chart in some way?
[2021-02-10 22:27:52]
Kiwi - Posts: 372
@sunnyd. I doubt it has much affect on SC as its about stopping an Nvidia daemon from restarting too often and our sessions with Sierra tend to be long anyway. But I'd be curious if ertrader gets any effect?

My distro hopping continues but might have finished. I decided I was unhappy with Fedora being owned by Red Hat who're owned by IBM, who might be pwned by NSA. And I've always wondered if systemd was a good thing as it extended its tentacles through Linux. Then Red Hat's true nature was as obvious as Donalds in his last big rally when it repurposed Centos. So I looked at Artix for its various init systems but it was too Archy (bleeding edge and a bit risky). Then I looked at Devuan which uses OpenRC and like Debian makes it easier to manage the newness vs risk balance. And here I am, free of the old X11 problem, free of systemd and with no risk of Wayland sneaking up on my pure and pretty XFCE and removing all the control X11 utilities give me.

System:
Host: home Kernel: 5.10.0-3-amd64 x86_64 bits: 64 Desktop: Xfce 4.16.0
Distro: Devuan GNU/Linux 4 (chimaera/ceres)
CPU:
Info: 6-Core AMD Ryzen 5 3600 [MT MCP] speed: 2202 MHz
min/max: 2200/3600 MHz
Graphics:
Device-1: NVIDIA GP108 [GeForce GT 1030] driver: nvidia v: 460.39
Display: x11 server: X.Org 1.20.10 driver: loaded: nvidia resolution:
1: 1920x1080~60Hz 2: 1920x1080~60Hz
OpenGL: renderer: GeForce GT 1030/PCIe/SSE2 v: 4.6.0 NVIDIA 460.39
Drives:
Local Storage: total: 2.84 TiB used: 1.6 TiB (56.2%)
Info:
Processes: 264 Uptime: N/A Memory: 15.64 GiB used: 999.5 MiB (6.2%)
Shell: Zsh inxi: 3.3.01

X11 version number: 11.0 X.Org version: 1.20.10
wine : wine-5.0.3 (Debian 5.0.3-3)

[2021-02-11 02:16:39]
ertrader - Posts: 568
@sunnyd. The Nvidia persistence setting was an attempt to address an OS instability issue. After being on for a few days, the computer would hang (completely freeze) regardless of what applications were running. The combination of this setting and updating to kernel 5.8 was the permanent fix for me for this issue.
Date Time Of Last Edit: 2021-02-11 02:26:26
[2021-02-11 03:09:03]
ganz - Posts: 1048
fyi:
https://www.gizmochina.com/2021/02/10/global-notebook-pc-shipments-q4-2020/

https://www.phoronix.com/scan.php?page=news_item&px=Lenovo-Platform-Profile-For-512

Kiwi
well ... congrats, sir.
it's your personal effort to keep the SC ver 4 Linux away

in order to be honest
and do not forget to get rid of:
- cellular phone
- any kind of medicine
- personal auto
- internet
- stop CME trading
and so on
pls think twice to deep into it

4ex: https://discourse.libsdl.org/t/sdl-moving-to-github/28700/5

ps: SC Support Board is a nice place to hate MS ... next to compile dll-s :)
Date Time Of Last Edit: 2021-02-11 03:52:02
[2021-02-20 00:58:26]
Kiwi - Posts: 372
I am thinking about dropping farcebook Ganz - fancy removing news feeds from Millions of Australian's who can't find the news without sweet Mark's help. Only reason I kept it was I'm admin on a couple of MITx boards. And I'd love to drop whatsapp except so many of the people I communicate with use it.

But the choice of Devuan, a really nice Debian derivative without systemd and with the extra control X gives me, doesn't imply a desire to drop any of the other things.

As to a Linux version of Sierra, I'll be overjoyed if it comes but I'm not actually holding my breath. Are you?
Date Time Of Last Edit: 2021-02-21 01:35:46
[2021-02-22 17:35:24]
TJezz - Posts: 4
Hi guys
I cannot make DTCBridge work with wine :(
The same config works fine in windoz..

I thougth it was wine-mono , but tried several wine+mono without success
Any clue?
Anyone using Rithmic in linux+wine ?


```

Rithmic Trading | Port for executable: 52497 | 2021-02-22 17:23:41.668
Listening socket (216). Port 52497 | Closed. | 2021-02-22 17:23:41.668
Rithmic Trading | Starting server: Z:\home\me\SierraChart_JEZZ\Rim\DTCBridge.exe | 2021-02-22 17:23:41.669
Error creating process Z:\home\me\SierraChart_JEZZ\Rim\DTCBridge.exe. Windows error code 1359: Internal error. | 2021-02-22 17:23:41.686 *
Rithmic Trading | Error running DTC server program Z:\home\me\SierraChart_JEZZ\Rim\DTCBridge.exe. | 2021-02-22 17:23:41.686 *
Error connecting to Data or Trading service. For help with this issue, press the 'Send For Analysis' button on this window. | 2021-02-22 17:23:41.686
Select 'File >> Disconnect' to prevent further connection attempts. | 2021-02-22 17:23:41.686
DTC Client socket (0) | CloseSocket call. | 2021-02-22 17:23:41.720
Rithmic Trading | Disconnected. | 2021-02-22 17:23:41.720

```

Thanks
[2021-02-22 19:28:50]
TJezz - Posts: 4
I cannot make DTCBridge work with wine :(
The same config works fine in windoz..

Found the problem: DTCBridge is 32bits and Sierra is 64bits. I was using a wine Appimage 64bits only.
Problem solved when installed wine with
sudo dpkg --add-architecture i386

Now trying to build a Wine Appimage with both 32 and 64 bits :)
[2021-02-22 19:48:56]
ertrader - Posts: 568
Good to hear! This will all get much better once the new Rithmic connection is up and running.

To post a message in this thread, you need to log in with your Sierra Chart account:

Login

Login Page - Create Account