Login Page - Create Account

Support Board


Date/Time: Fri, 17 Sep 2021 05:00:54 +0000



Post From: IsReplayRunning() incorrect on last bar

[2021-07-07 16:52:11]
User660727 - Posts: 23
Below is a log showing all study calls during a replay from 7/7/21 10:55
The last tick of available data is at 10:59:14
The study is set for manual looping
The chart is configured for 1 minute bars
Sierra Chart is disconnected
Attached are the replay settings and the last tick of data for the symbol

As you can see:
IsReplayRunning is turned off starting at 10:58. Shouldn't this be set thru the last bar at 10:59?
GetReplayHasFinishedStatus is set at 10:58. Shouldn't this be set at the 10:59 bar?
The last bar of the replay (10:59) is called twice but with both flags cleared. Why is the last bar not included in the replay?


IsReplayRunning:0 GetReplayHasFinishedStatus:0 UpdateStartIndex:10,494 2021-07-7 10:59:00
IsReplayRunning:0 GetReplayHasFinishedStatus:0 UpdateStartIndex:0 2021-06-27 17:00:00
IsReplayRunning:0 GetReplayHasFinishedStatus:0 UpdateStartIndex:10,494 2021-07-7 10:59:00
IsReplayRunning:1 GetReplayHasFinishedStatus:0 UpdateStartIndex:0 2021-06-27 17:00:00
IsReplayRunning:1 GetReplayHasFinishedStatus:0 UpdateStartIndex:10,490 2021-07-7 10:55:00
IsReplayRunning:1 GetReplayHasFinishedStatus:0 UpdateStartIndex:10,491 2021-07-7 10:56:00
IsReplayRunning:1 GetReplayHasFinishedStatus:0 UpdateStartIndex:10,492 2021-07-7 10:57:00
IsReplayRunning:0 GetReplayHasFinishedStatus:1 UpdateStartIndex:10,493 2021-07-7 10:58:00
IsReplayRunning:0 GetReplayHasFinishedStatus:0 UpdateStartIndex:10,494 2021-07-7 10:59:00
IsReplayRunning:0 GetReplayHasFinishedStatus:0 UpdateStartIndex:10,494 2021-07-7 10:59:00


imagereplay.png / V - Attached On 2021-07-07 16:45:01 UTC - Size: 24.89 KB - 37 views
imagelast tick.png / V - Attached On 2021-07-07 16:45:10 UTC - Size: 26.24 KB - 35 views