Login Page - Create Account

Support Board


Date/Time: Sat, 26 Nov 2022 23:54:47 +0000



Break Even Button

View Count: 165

[2022-10-05 17:27:12]
Technical - Posts: 118
I have set up a DOM with a break-even button set to "Trade Move Stop to Break Even".

When I activate that button the it either moves the stop off the visible DOM or closes the position altogether. Can you tell me what I am doing incorrectly?

Thank you.
Private File
[2022-10-05 17:58:18]
John - SC Support - Posts: 20144
There is an offset that is applied to the Move to BreakEven. Refer to the following:
Basic Trading and the Trade Window: Set >> Move to BE Offset

You probably want to set this to 0 to start and ensure that the Move to BE option works as expected.
For the most reliable, advanced, and zero cost futures order routing, use the Teton service:
Sierra Chart Teton Futures Order Routing
[2022-10-05 18:19:07]
Technical - Posts: 118
On my trade window, the Move to BE Offset is set to 0. I tried setting it to 1, no change. It moves it to 38.00. See enclosure.

This is acting as if the "Move to BE Offset" was a high negative number as it goes way off screen.

I am on 2439 by the way.
image2022-10-05 13_15_52-Trade Orders.png / V - Attached On 2022-10-05 18:18:43 UTC - Size: 69.61 KB - 29 views
[2022-10-06 16:18:43]
Sierra_Chart Engineering - Posts: 5281
Provide us that chart you are trading from, following these instructions:
Support Board Posting Information: Providing Chartbook with Only a Single Chart
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. Try to keep your questions brief and to the point. Be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

For the most reliable, advanced, and zero cost futures order routing, use the Teton service:
Sierra Chart Teton Futures Order Routing
[2022-10-06 17:12:42]
Technical - Posts: 118
Ok, this is the chartbook I use, it supports the DOM.
Private File
[2022-10-07 10:02:26]
Sierra_Chart Engineering - Posts: 5281
We do see a problem with this and we are looking into the cause and will resolve.

The problem relates to this new requested feature variable:
AlwaysUsePositionAveragePriceForReferencePriceForBreakEvenCommand

It did not support, a chart Price Multiplier other than 1.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. Try to keep your questions brief and to the point. Be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

For the most reliable, advanced, and zero cost futures order routing, use the Teton service:
Sierra Chart Teton Futures Order Routing
Date Time Of Last Edit: 2022-10-07 10:06:40
[2022-10-08 13:32:22]
Technical - Posts: 118
Am I understanding that this may be incorrect? Please see screenshot.
image2022-10-08 08_30_35-Symbol Settings.png / V - Attached On 2022-10-08 13:32:03 UTC - Size: 42 KB - 17 views
[2022-10-08 17:20:09]
Sierra_Chart Engineering - Posts: 5281
The default Symbol Settings are correct. There is no issue there. The issue is resolved. Update to the latest prerelease.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. Try to keep your questions brief and to the point. Be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

For the most reliable, advanced, and zero cost futures order routing, use the Teton service:
Sierra Chart Teton Futures Order Routing

To post a message in this thread, you need to log in with your Sierra Chart account:

Login

Login Page - Create Account