Login Page - Create Account

Support Board


Date/Time: Tue, 16 Aug 2022 21:53:07 +0000



History Problem

View Count: 843

[2014-02-17 11:17:27]
golan_82 - Posts: 24
Hi ,
When I open today the sierra , I can't see today's history , only from the moment I opened the sierra it starts to show data but don't save the data when I close the sierra. It happens for all contracts. and I see the history of the last day (friday) and back on. the problem somehow only today for today's data

thanks
[2014-02-17 13:57:28]
jesslinn - Posts: 108
I am having a possibly related problem, but I am not sure when it started. The problem seems to be occurring only with historical (daily) data on the SC futures feed and I might have been having it since Jan 30 or possibly since Feb 12 when I upgraded to 1091 NonCLR.

Specifically, if I erase all SI files from the data directory and do a find symbol and pick SIH14, I get SIH14 in Symbol: and SI-201403-NYMEX-USD-5000 in Trade and Current Quote Symbol: as expected but I only get a single daily bar from today. If I copy in an SIH14.dly file from backup, I get all of the days in the file and today but no daily bars in between.

I am running 1091-NonCLR with Interactive Brokers and SC Futures enabled.

[2014-02-17 14:27:26]
jesslinn - Posts: 108
I just tried this again to verify. That is I erased all SI symbols, then did a find symbol. This time, if I look under futures for Interactive Brokers [This Instance] I do not see SIH14 but only SI-201403-NYMEX-USD-5000. When I pick that and choose historical I get an SIH14.dly file and the same set up and problem as before. (I may have been mistaken about what was available to pick the first time.)

I do note that the same problem is happening with ES.
[2014-02-17 16:55:43]
Sierra Chart Engineering - Posts: 104220

When I open today the sierra , I can't see today's history , only from the moment I opened the sierra it starts to show data but don't save the data when I close the sierra. It happens for all contracts. and I see the history of the last day (friday) and back on. the problem somehow only today for today's data
You are using the OEC trading service. The problem is now resolved. Refer to help topic 7.1 download the missing data:
https://www.sierrachart.com/index.php?l=doc/helpdetails7.html#RetryDownloadDataInChart
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. Try to keep your questions brief and to the point. Be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

For the most reliable, advanced, and zero cost futures order routing, *change* to the Teton service:
Sierra Chart Teton Futures Order Routing
[2014-02-17 17:01:29]
Sierra Chart Engineering - Posts: 104220
I just tried this again to verify. That is I erased all SI symbols, then did a find symbol. This time, if I look under futures for Interactive Brokers [This Instance] I do not see SIH14 but only SI-201403-NYMEX-USD-5000. When I pick that and choose historical I get an SIH14.dly file and the same set up and problem as before. (I may have been mistaken about what was available to pick the first time.)
We are not seeing a problem with this. Restart Sierra Chart, open a chart for that symbol again and then post a copy of the Message Log, by following these steps:
https://www.sierrachart.com/index.php?l=PostingInformation.php#log
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. Try to keep your questions brief and to the point. Be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

For the most reliable, advanced, and zero cost futures order routing, *change* to the Teton service:
Sierra Chart Teton Futures Order Routing
[2014-02-18 03:15:49]
jesslinn - Posts: 108
The log shows Error Code 18 and an http error both for downloading the global symbol list and for downloading historical data. Real-time updates work OK.

SOLVED: The problem appears to have been caused by a system update of wine. I am not sure what version I had before but now I have 1.6.1 and it does not work. I changed to crossover and the problem does not occur.

Thanks for responding.


To post a message in this thread, you need to log in with your Sierra Chart account:

Login

Login Page - Create Account