Login Page - Create Account

Support Board


Date/Time: Mon, 17 Feb 2020 11:43:45 +0000



[Programming Help] - SpreadSheet Auto Trade - Exit and Entry orders not executing

[2020-01-16 06:37:36]
a Gem Tree - Posts: 38 | Ending Date: 2020-03-11
My order entries and exits are not working properly. Sometimes they work - sometimes they don't

I'm pretty sure that the code is written well - Because if I pause during the replay tool and refresh the chart, the trade entry will appear where it should have after bar close. Even if I'm 3-4 bars past the trigger signal - and I refresh and reload the chart - the order entry will still reappear at a price level only available to the bar after the trigger.
Date Time Of Last Edit: 2020-01-16 07:15:01
[2020-01-16 07:05:15]
a Gem Tree - Posts: 38 | Ending Date: 2020-03-11
I looked up a possible solution in another thread ---- Turning Reset Condition on new bar - to TRUE.

"If a cell is TRUE and there is a new bar and the cell continues to be TRUE, because the state is already TRUE, you will not get a new signal unless the input Reset Condition on New Bar is set to Yes. If a TRUE signal has been given by the formula in a cell and then it goes back to FALSE and back to TRUE on the same bar, you will not get a signal if Signal Only Once Per Bar is set to Yes. If you have the Signal Only On Bar Close (Column K,M) input set to Yes, then a TRUE signal will be ignored on cells K3 and M3, and only the cells K4 and M4 will be monitored for signals. Likewise with the Signal Only On Bar Close (Column L,N-Z) input. In all these cases, when a signal is ignored, there is no message added to the Trade Service Log or the Alerts Log, except in the case of the Spreadsheet System for Trading study when the signal has been ignored as the result of Signal Only Once Per Bar ."


However, the spreadsheet still fails to enter a trade consistently. I'd say about 1 out of every 4 replays results in a trade entry, the rest require me to refresh the page.


I've also noticed, that when I alter code, or settings in the spreadsheet, a bunch of trade signals (red and green arrows) appear everywhere.
When I refresh the chart, they all go away.
This started very recently, and I'm not sure what I've done wrong.
Maybe you guys will know what is going on.
Date Time Of Last Edit: 2020-01-16 07:25:32

To post a message in this thread, you need to login with your Sierra Chart account:

Login

Login Page - Create Account