Login Page - Create Account

Support Board


Date/Time: Tue, 23 Oct 2018 10:54:23 +0000



NetPL: in Trade Window inconsistent with P/L after Close of Trad

Support Request:
[2013-04-11 10:11:41]
Rainer - Posts: 95
P/L: and NetPL: in Trade Window show correct currency values during [FOREX] [SIM] open trade; and just after having cleared the Log. Soon as the trade is closed, the P/L: value shows correct (1.00C) but the NetPL: shows 10000.00C instead of 1.00C ... (see attached pics)
Then, when open the next trade (assume position is then already in 3 pips profit), the NetPL: (during the trade shows 10003.00C), then when trade is closed, NetPL: shows 40000.00C
Can you please explain why NetPL: behaves like this and/or offer solution?
imageSC Net PL1.JPG / V - Attached On 2013-04-11 10:00:16 UTC - Size: 155.36 KB - 209 views
imageSC Net PL2.JPG / V - Attached On 2013-04-11 10:09:09 UTC - Size: 164.21 KB - 157 views
[2013-04-12 01:29:18]
Sierra Chart Engineering - Posts: 65120
We do not observe this. Please check the Symbol Settings in Global Settings >> Symbol Settings.

What is the Currency Value per Tick and the Tick Size set to for this particular symbol?
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

If your question/request has been answered and you do not have anything further, then it is easiest for us if you do not reply again to say thank you.
[2013-04-12 01:41:30]
Rainer - Posts: 95
see attached. Remember and as described above, (after clearing the Log, or with a new 24hr period) the first fresh Entry shows NetPL: correct (5.00C, if 5 pips [FOREX] in profit), but soon as Entry is closed, the NetPL: shows 50000.00C
imageSC Net PL3.JPG / V - Attached On 2013-04-12 01:39:57 UTC - Size: 129.12 KB - 160 views
[2013-04-12 02:23:10]
Sierra Chart Engineering - Posts: 65120
The Currency Value per Tick in Global Symbol Settings needs to be .0001. It is 1.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

If your question/request has been answered and you do not have anything further, then it is easiest for us if you do not reply again to say thank you.
[2013-04-12 03:17:32]
Rainer - Posts: 95
this did not make any difference, exactly same behavior as above; see attached pic (I even cleared the Log again and did SaveAll before this exercise)
note: If the Tick-size is 0.0001, and this then represents 1 pip, how can then the currency value for 0.0001 (=1 pip) be worth $0.0001 when in real life (AUDUSD) one pip is worth around $1 (not one-ten-thousand's of a dollar; 0.0001).
There must be some other factors within the program as it appears to behave different during a Trade and different after close of Trade.
Date Time Of Last Edit: 2013-04-12 03:18:31
[2013-04-12 03:25:19]
Sierra Chart Engineering - Posts: 65120
It will make a difference if you go to Chart >> Reload and Recalculate.


Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

If your question/request has been answered and you do not have anything further, then it is easiest for us if you do not reply again to say thank you.
[2013-04-12 03:55:24]
Rainer - Posts: 95
no difference again. I did clear the Log, then Reload and Recalculate (on the same chart as this exercise) then same exercise again and still no difference. When in the Trade, the NetPL: fluctuates between 9999.00C & 9998.00C (while the P/L: fluctuates between -1.00C & -2.00C) (see attached pic). Then when Trade closed, the NetPL: shows -9998.00C instead of -2.00C (note. Symbol Settings are still at modified settings as per ur last instructions.)
imageSC Net PL5.JPG / V - Attached On 2013-04-12 03:49:01 UTC - Size: 29.62 KB - 148 views
[2013-04-12 06:07:05]
Sierra Chart Engineering - Posts: 65120
Select Global Settings >> Symbol Settings. At the top of the window you will notice a Service setting. Check the symbol you have a problem with, for each Service where it has settings and make certain the Currency Value Per Tick is correct.
Sierra Chart Support - Engineering Level

Your definitive source for support. Other responses are from users. If possible please keep your questions brief and to the point. Please be aware of support policy:
https://www.sierrachart.com/index.php?l=PostingInformation.php#GeneralInformation

If your question/request has been answered and you do not have anything further, then it is easiest for us if you do not reply again to say thank you.
Date Time Of Last Edit: 2013-04-12 06:07:35
[2013-04-12 06:24:27]
Rainer - Posts: 95
Settings were correct. Then (this time) I closed and re-opened SC totally, and now it works. Thanks for ur patience.

To post a message in this thread, you need to login with your Sierra Chart account:

Login


Login Page - Create Account