Login Page - Create Account

Support Board


Date/Time: Wed, 17 Oct 2018 19:46:40 +0000



[User Discussion] - Best way to run SC on Linux and connect to IB?

Support Request:
[2013-04-09 23:01:17]
maxpi - Posts: 98
I'm getting familiar with Ubuntu. I have sierrachart running via wine. I'm trying to install and connect to the TWS API. I tried to install TWS standalone native to linux and ran into problems, I tried to install it to run via wine. I wound up with the TWS shortcut on the desktop but when I click on it I get a file not found error. I tried running the Webtrader in Firefox but Sierrachart doesn't seem to connect to it [is it supposed to?].
[2013-04-10 13:53:22]
sailor_nate - Posts: 4
I have been running SC on Linux for over 2 years now and here's what I would recommend... You can run SC under wine and it will work perfectly fine either Non-.NET/CLR or regular version (takes more effort to get working and versions needing .NET 4.0 are not fully supported) see this thread if you are still interested in this route...

http://www.sierrachart.com/supportboard/showthread.php?t=32719&highlight=linux

When I was running under Wine I used the regular version and installed the Wine components listed on that link and was able to get most all features working including spreadsheets. The only thing that would not work at the time was compiling code and chart replay... no biggie

That was my setup about a year ago, Currently I cannot get the latest version to work under Wine due to the .NET 4.0 requirement so I've moved everything to a virtual Windows 7 machine running under QEMU-KVM. I run TWS using the native Linux version with OpenJDK java and it works really flawlessly for me.

So to sum up, if you want the latest version of SC to work properly on Linux run under a Windows virtual machine (either QEMU-KVM or VirtualBox will work fine) and use IB's TWS for UNIX. OR you can try to use the Non .NET version under Wine as an alternative to having a Windows license. You should be good to go, this setup is extremely reliable for me.
Date Time Of Last Edit: 2013-04-10 13:56:31
[2013-04-10 14:51:15]
maxpi - Posts: 98
That is very useful info.

My immediate goal is to have an install that I can take with me on a keychain. Currently I'm trying to mount the whole thing on a thumb drive. I'm using an app from pendrivelinux.com to install Ubuntu to a thumb drive. The Non-Net Sierrachart software works fine in that environment using wine but I'm not able to follow the directions at the IB website to get the native unix version to install in Ubuntu. IB's instructions leave out a lot of things that are more related to installing some of the software needed before their app can be installed. I'm at the terminal, in the proper directory, with the proper file in said directory and I type[from IB's website]:

java -cp jts.jar:hsqldb.jar:jcommon-1.0.12.jar:jfreechart-1.0.9.jar:jhall.jar:other.jar:rss.jar -Xmx512M -XX:MaxPermSize=128M jclient.LoginFrame .

That is supposed to install TWS... I get this error message: "Error: Could not find or load main class jclient.LoginFrame"

It seems like I need to change a path or something?
[2013-04-10 15:00:17]
sailor_nate - Posts: 4
make sure that you are in the directory containing all of the .jar files and make sure the java command you are running is in the search path when you execute that command. What I do is create a Bash script and point to each of the .jar files and the java executable individually with the full path included. There is no installation like in Windows... that command starts TWS. Under Linux, simply putting the files in a directory is considered installing the software, simple and clean.

Date Time Of Last Edit: 2013-04-10 15:01:40
[2013-04-10 15:52:22]
sailor_nate - Posts: 4
I forgot to ask, have you extracted the the individual jar files (jts.jar,hsqldb.jar,etc) from the unixmacosx.jar file?

jar xf unixmacosx.jar


[2013-04-10 16:49:40]
maxpi - Posts: 98
I have made a directory called IBJts and put a file in it called "unixmacosx_latest.jar" Then while in that directory I ran "jar xf unixmacosx_latest.jar". I don't see any extracted files in that directory however.
Date Time Of Last Edit: 2013-04-10 16:55:27
[2013-04-10 16:52:48]
sailor_nate - Posts: 4
Once you are in the IBJts directory issue the command:

jar xf unixmacosx_latest.jar

you can then verify the files are there by using

ls -l

you should see 7 .jar files and 1 .ini file
[2013-04-10 22:05:55]
maxpi - Posts: 98
The command seemingly runs but when I do ls -l I see just one file:

ubuntu@ubuntu:~/IBJts$ ls -l
total 39448
drwxrwxr-x 2 ubuntu ubuntu 200 Apr 5 15:26 IBJts
-rw-rw-r-- 1 ubuntu ubuntu 40393156 Apr 10 21:46 unixmacosx_latest.jar


the first time I issued that commmand there was missing program so I installed it as suggested. I went with the default one.. I can't get back to the original command but I see a lot references to openjdk... The second time I ran the jar command I didn't see the notice about a need to install anything and it acted like it functioned but ls -l shows it didn't.
Date Time Of Last Edit: 2013-04-10 22:15:05
[2013-04-10 22:19:42]
maxpi - Posts: 98
actually there is a difference after running the command, it created a subdirectory with the same name.. I do a ls -l in that directory:

ubuntu@ubuntu:~/IBJts/IBJts$ ls -l
total 43504
-rw-rw-r-- 1 ubuntu ubuntu 1748483 Mar 21 13:12 hsqldb.jar
-rw-rw-r-- 1 ubuntu ubuntu 307734 Mar 21 13:12 jcommon-1.0.12.jar
-rw-rw-r-- 1 ubuntu ubuntu 1291498 Mar 21 13:12 jfreechart-1.0.9.jar
-rw-rw-r-- 1 ubuntu ubuntu 556956 Mar 21 13:12 jhall.jar
-rw-rw-r-- 1 ubuntu ubuntu 40 Apr 5 15:27 jts.ini
-rw-rw-r-- 1 ubuntu ubuntu 39908745 Mar 21 13:13 jts.jar
-rw-rw-r-- 1 ubuntu ubuntu 313201 Mar 21 13:12 other.jar
-rw-rw-r-- 1 ubuntu ubuntu 403994 Mar 21 13:12 rss.jar
ubuntu@ubuntu:~/IBJts/IBJts$



[2013-04-10 22:22:21]
maxpi - Posts: 98
Well wow... once I understood the instructions it worked as per.... drumroll..... The Instructions!! Crazy, who'da thought?

Nate, thank you very much for the help and the encouragement.

To post a message in this thread, you need to login with your Sierra Chart account:

Login


Login Page - Create Account