Login Page - Create Account

Support Board


Date/Time: Tue, 17 Jul 2018 07:56:46 +0000



Post From: confuse about data feed

[2017-12-16 08:58:48]
User245723 - Posts: 6
i want to use depth of market on spot fx..and i have no brooker right now support sierra chart..so im confuse which package and data feed i need to active

so i try read on support board and many use LMAX data feed for spot fx..
so for package 5 is 33usd + how much for LMAX?