Secure Browsing


Introduction

TLS (Transport Layer Security) version 1.1 or higher needs to be enabled on your web browser to access the PCI DSS (data security standard) compliant payments server.

Supported Browsers

Firefox - (Recommended)

We recommend the use of Firefox. You can download it from here.

Make sure you are running the latest versions of Firefox. TLS 1.1 and TLS 1.2 are enabled by default starting with version 27.

Chrome

Make sure you are running the latest versions of Chrome. TLS 1.1 and 1.2 are enabled by default.

Opera

Make sure you are running the latest versions of Opera. You also need to enable TLS 1.1 and TLS 1.2 in Opera under Opera >> Settings >> Preferences >> Advanced >> Security >> Security Protocols.

Internet Explorer (IE)

Make sure you are running the latest versions of Internet Explorer. Make sure TLS 1.1 and 1.2 are enabled under Tools >> Internet Options >> Advanced, you will need to scroll down to the Security section.


*Last modified Saturday, 10th September, 2016.